narkive is for sale. Interested? (dismiss)
Discussion:
Error in installing certificate Using certenroll
(too old to reply)
b***@gmail.com
2007-07-20 12:10:43 UTC
Permalink
Hi frndz ,

Im in using windows Vista machine.
Im doing certificate enrollment process in javascript using certEnroll
functions .

My problem is
Im successfully generating the CSR and giving it to CA and
getting the certficate , again while installing the certificate , it
is throwing some errors , my code is given below

var cert="-----BEGIN CERTIFICATE-----
MIICNTCCAZ6gAwIBAgIENzM5ODANBgkqhkiG9w0BAQUFADBUMQswCQYDVQQGFgJJTjELMAkGA1UECBYCVE4xEzARBgNVBAoWClNlY3VyZUJhbmsxCzAJBgNVBAsWAklUMRYwFAYDVQQDFg1TZWN1cmVCYW5rIENBMB4XDTA3MDUyMzEzMjQ0M1oXDTA4MDUyMjEzMjQ0M1owajERMA8GA1UEAxYITmV3VXNlcjgxCzAJBgNVBAYWAklOMRMwEQYDVQQIFgpUYW1pbCBOYWR1MRMwEQYGKxICBIVBFgdDaGVubmFpMQwwCgYDVQQKFgNPVEwxEDAOBgNVBAsWB1Nub3JrZWwwgZ8wDQYJKoZIhvcNAQEBBQADgY0AMIGJAoGBAMhxoE6JmgIin7hCj
+Nk56epm9jf+fBclE2FQisV23ovdVPzLz8c9IP7HhCRz/bHWnW6h7Hqeh3e4WoGd
+LtB6k4LtYLBUL+FHHcgZ5Z5ZrgE97sEts18dVeVzGyR4L7NsFgUqdkVMyG6ZyAN/
Z8GPDaGycl+xQlWid/uT4j7hZbAgMBAAEwDQYJKoZIhvcNAQEFBQADgYEAiwYbxKH6H
+hUBHpVgX0nTCusxyxgYeVY0bN5F7vGfRS8XwBGlYGWCvpa5jdE61DxXC1uXepQr3G/
ppWOqnUj57f0AwxsNuIvrWpCA8kbI2kQnW0KwEgMzCSs+/pocKkNAoWnM9s+
+pr9QCv8phA9m01RPMGHjUfsNALIJ/rkze8=-----END CERTIFICATE-----"

var enrollment = new ActiveXObject("X509Enrollment.CX509Enrollment");
enrollment.Initialize(1);
--> enrollment.InstallResponse(7,cert,0,"");

In the arrow marked line , it showing the error like ,

"InstallResponse: cannot find object or property 0x80092004"

I have some other code, which directly generates certificate using
certEnroll function , which is a self-signed one.
, that certificate is installing properly with the same code

Can anyone say why it is happening and how resolve this

Thankz
Dinesh
Haitao Li
2007-07-20 18:37:12 UTC
Permalink
Check the event log and see if there are any error messages related to
certenroll. If there is nothing, please collect a log file:

certutil -setreg Enroll\debug 0xffffffe3
restart the enrolling process and repro the failure
certutil -delreg Enroll\debug
Provide the log file in %windir%\certenroll.log or
%userprofile%\certenroll.log
Post by b***@gmail.com
Hi frndz ,
Im in using windows Vista machine.
Im doing certificate enrollment process in javascript using certEnroll
functions .
My problem is
Im successfully generating the CSR and giving it to CA and
getting the certficate , again while installing the certificate , it
is throwing some errors , my code is given below
var cert="-----BEGIN CERTIFICATE-----
MIICNTCCAZ6gAwIBAgIENzM5ODANBgkqhkiG9w0BAQUFADBUMQswCQYDVQQGFgJJTjELMAkGA1UECBYCVE4xEzARBgNVBAoWClNlY3VyZUJhbmsxCzAJBgNVBAsWAklUMRYwFAYDVQQDFg1TZWN1cmVCYW5rIENBMB4XDTA3MDUyMzEzMjQ0M1oXDTA4MDUyMjEzMjQ0M1owajERMA8GA1UEAxYITmV3VXNlcjgxCzAJBgNVBAYWAklOMRMwEQYDVQQIFgpUYW1pbCBOYWR1MRMwEQYGKxICBIVBFgdDaGVubmFpMQwwCgYDVQQKFgNPVEwxEDAOBgNVBAsWB1Nub3JrZWwwgZ8wDQYJKoZIhvcNAQEBBQADgY0AMIGJAoGBAMhxoE6JmgIin7hCj
+Nk56epm9jf+fBclE2FQisV23ovdVPzLz8c9IP7HhCRz/bHWnW6h7Hqeh3e4WoGd
+LtB6k4LtYLBUL+FHHcgZ5Z5ZrgE97sEts18dVeVzGyR4L7NsFgUqdkVMyG6ZyAN/
Z8GPDaGycl+xQlWid/uT4j7hZbAgMBAAEwDQYJKoZIhvcNAQEFBQADgYEAiwYbxKH6H
+hUBHpVgX0nTCusxyxgYeVY0bN5F7vGfRS8XwBGlYGWCvpa5jdE61DxXC1uXepQr3G/
ppWOqnUj57f0AwxsNuIvrWpCA8kbI2kQnW0KwEgMzCSs+/pocKkNAoWnM9s+
+pr9QCv8phA9m01RPMGHjUfsNALIJ/rkze8=-----END CERTIFICATE-----"
var enrollment = new ActiveXObject("X509Enrollment.CX509Enrollment");
enrollment.Initialize(1);
--> enrollment.InstallResponse(7,cert,0,"");
In the arrow marked line , it showing the error like ,
"InstallResponse: cannot find object or property 0x80092004"
I have some other code, which directly generates certificate using
certEnroll function , which is a self-signed one.
, that certificate is installing properly with the same code
Can anyone say why it is happening and how resolve this
Thankz
Dinesh
b***@gmail.com
2007-07-21 05:23:41 UTC
Permalink
Haitao Li
2007-07-23 18:08:49 UTC
Permalink
You need to run it from elevated command prompt. Click "start", type in cmd,
then right click on cmd.exe and select "run as administrator".

<***@gmail.com> wrote in message news:***@e16g2000pri.googlegroups.com...

if i gave "certutil -setreg Enroll\debug 0xffffffe3 " it is asking
adminitrator command though im in administrator login
Post by Haitao Li
Check the event log and see if there are any error messages related to
certutil -setreg Enroll\debug 0xffffffe3
restart the enrolling process and repro the failure
certutil -delreg Enroll\debug
Provide the log file in %windir%\certenroll.log or
%userprofile%\certenroll.log
Post by b***@gmail.com
Hi frndz ,
Im in using windows Vista machine.
Im doing certificate enrollment process in javascript using certEnroll
functions .
My problem is
Im successfully generating the CSR and giving it to CA and
getting the certficate , again while installing the certificate , it
is throwing some errors , my code is given below
var cert="-----BEGIN CERTIFICATE-----
MIICNTCCAZ6gAwIBAgIENzM5ODANBgkqhkiG9w0BAQUFADBUMQswCQYDVQQGFgJJTjELMAkGA1U­ECBYCVE4xEzARBgNVBAoWClNlY3VyZUJhbmsxCzAJBgNVBAsWAklUMRYwFAYDVQQDFg1TZWN1cm­VCYW5rIENBMB4XDTA3MDUyMzEzMjQ0M1oXDTA4MDUyMjEzMjQ0M1owajERMA8GA1UEAxYITmV3V­XNlcjgxCzAJBgNVBAYWAklOMRMwEQYDVQQIFgpUYW1pbCBOYWR1MRMwEQYGKxICBIVBFgdDaGVu­bmFpMQwwCgYDVQQKFgNPVEwxEDAOBgNVBAsWB1Nub3JrZWwwgZ8wDQYJKoZIhvcNAQEBBQADgY0­AMIGJAoGBAMhxoE6JmgIin7hCj
+Nk56epm9jf+fBclE2FQisV23ovdVPzLz8c9IP7HhCRz/bHWnW6h7Hqeh3e4WoGd
+LtB6k4LtYLBUL+FHHcgZ5Z5ZrgE97sEts18dVeVzGyR4L7NsFgUqdkVMyG6ZyAN/
Z8GPDaGycl+xQlWid/uT4j7hZbAgMBAAEwDQYJKoZIhvcNAQEFBQADgYEAiwYbxKH6H
+hUBHpVgX0nTCusxyxgYeVY0bN5F7vGfRS8XwBGlYGWCvpa5jdE61DxXC1uXepQr3G/
ppWOqnUj57f0AwxsNuIvrWpCA8kbI2kQnW0KwEgMzCSs+/pocKkNAoWnM9s+
+pr9QCv8phA9m01RPMGHjUfsNALIJ/rkze8=-----END CERTIFICATE-----"
var enrollment = new ActiveXObject("X509Enrollment.CX509Enrollment");
enrollment.Initialize(1);
--> enrollment.InstallResponse(7,cert,0,"");
In the arrow marked line , it showing the error like ,
"InstallResponse: cannot find object or property 0x80092004"
I have some other code, which directly generates certificate using
certEnroll function , which is a self-signed one.
, that certificate is installing properly with the same code
Can anyone say why it is happening and how resolve this
Thankz
Dinesh- Hide quoted text -
- Show quoted text -
r***@gmail.com
2013-11-26 10:20:09 UTC
Permalink
Please let me know solution I am facing same issue with certenroll.
Loading...